5

I want to install Logstash and others, but when I try:

# yum install libevent-devel

I get the errors below:

Transaction Check Error:
  file /usr/bin/event_rpcgen.py from install of libevent-devel-2.0.12-1.rhel6.i686 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.i686
  file /usr/lib/libevent_core.a from install of libevent-devel-2.0.12-1.rhel6.i686 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.i686
  file /usr/lib/libevent_core.so from install of libevent-devel-2.0.12-1.rhel6.i686 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.i686
  file /usr/lib/libevent_extra.a from install of libevent-devel-2.0.12-1.rhel6.i686 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.i686
  file /usr/lib/libevent_extra.so from install of libevent-devel-2.0.12-1.rhel6.i686 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.i686

Please give me advice to solve this error conflict.

# rpm -qi compat-libevent14
Name        : compat-libevent14            Relocations: (not relocatable)
Version     : 1.4.13                            Vendor: (none)
Release     : 1.rhel6                       Build Date: Mon 19 Sep 2011 04:50:45 PM WIT
Install Date: Fri 28 Oct 2011 10:10:03 PM WIT      Build Host: koji-sl6-i386-pg91
Group       : System Environment/Libraries   Source RPM: compat-libevent14-1.4.13-1.rhel6.src.rpm
Size        : 427200                           License: BSD
Signature   : DSA/SHA1, Mon 19 Sep 2011 04:50:45 PM WIT, Key ID 1f16d2e1442df0f8
URL         : http://monkey.org/~provos/libevent/
Summary     : Abstract asynchronous event notification library
Description :
The libevent API provides a mechanism to execute a callback function
when a specific event occurs on a file descriptor or after a timeout
has been reached. libevent is meant to replace the asynchronous event
loop found in event driven network servers. An application just needs
to call event_dispatch() and can then add or remove events dynamically
without having to change the event loop.
  • Where did you get that compat-libevent14 package? Run rpm -qi compat-libevent14. – Michael Hampton Aug 4 '13 at 15:51
5

Your existing version of compat-libevent14 comes from the PostgreSQL yum repository. There is a bug open on the conflict between compat-libevent14 and libevent-devel. And another one.

Assuming that you need the PostgreSQL repository enabled, your best course of action would be to remove compat-libevent14 and install libevent and libevent-devel from the PostgreSQL repository. This will necessitate removing any packages that require compat-libevent14, so only you can decide whether this is a reasonable course of action.

If this doesn't work out, your options are generally (a) contact the maintainers of the PostgreSQL yum repository and see if they have any plans to resolve those bugs or (b) fix the problem yourself and roll your own packages.

2

If you don't have any need for compat-libevent14 or for the version of libevent provided in the PostgreSQL repo, you can add exclude directives to the PostgreSQL repo file.

In /etc/yum.repos.d/pgdg-93-centos.repo you can edit the [pgdg93] section and add the following line:

exclude=*libevent*

Make sure you add it to the correct section in the repo file. This will exclude any libevent packages from the PostgreSQL repo and your package installations won't have package clashes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.