2

Linux noob here. How can I disable root login for dropbear? What I've done so far

  • adding DROPBEAR_EXTRA_ARGS="-w -g" into /etc/default/dropbear (not working)
  • adding DROPBEAR_EXTRA_ARGS="-w -g" into /etc/init.d/dropbear (not working too)

Dropbear version dropbear-0.58-1.el6.i686.rpm installed on centos 6.

Please help.

Thanks

3
  • 1
    Why are you using Dropbear and not OpenSSHd? Aug 5 '13 at 9:26
  • Sorry, this just popped straight to my mind.. have you restarted the dropbear service?
    – Isaac Kwan
    Aug 5 '13 at 9:30
  • Do those options actually get added to the process when it's restarted? You can check with ps -ef | grep dropbear.
    – Ladadadada
    Aug 5 '13 at 9:59
3

Based on looking at the /etc/init.d/dropbear script from dropbear-0.58-1.el6.i686.rpm I'd say you need to have the following line in the config file /etc/sysconfig/dropbear:

OPTIONS=-w -g

After modifying the file, restart the dropbear service. If all goes well, using ps -efw | grep dropbear should show that the options have really been passed to the executable.

Not the answer you're looking for? Browse other questions tagged or ask your own question.