0

I have been trying to fix my Postfix server, but somehow it still don't want to accept emails from any places. From gmail I get this error:

Delivery to the following recipient failed permanently:

support@xxx

Technical details of permanent failure: Google tried to deliver your message, but it was rejected by the server for the recipient >domain xxx by mail.xxx. [ip.address.here].

The error that the other server returned was: 554 5.7.1 : Relay access denied

This is my postfix config:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
disable_vrfy_command = yes
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
myhostname = CHANGED HOSTNAME
mynetworks_style = host
myorigin = $myhostname
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 550

I have been trying to find a solution for hours and I have visited and tried almost everything.

Please help me out

closed as off-topic by Ward, mdpc, Magellan, Christopher Perrin, Andrew B Aug 9 '13 at 4:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Ward, Magellan, Christopher Perrin, Andrew B
If this question can be reworded to fit the rules in the help center, please edit the question.

1

@Jaan Postfix will accept the mail only if the email address falls under anyone of the following address classes.

  • Local domain Class
  • virtual Alias Class
  • Virtual mailbox class
  • Relay class

Or if the connecting host is listed under mynetworks (default class). More about postfix address classes here

Your screenshots show that you are setting up your domain xxx as local domain class. i have never used any GUI for postfix administration. Ensure the following configurations exist in main.cf

mydestination = xxx
# to consider xxx domain as local address class
# add localhost localhost.$mydomain also to mydestination after your testing
# valid users under mydestination domains should be specified using local_recipient_maps

#local_recipient_maps = proxy:unix:passwd.byname $alias_maps
# commented it out, because default setting is proxy:unix:passwd.byname $alias_maps
# Now all your UNIX users and special aliases in $alias_maps can receive mails

Not the answer you're looking for? Browse other questions tagged or ask your own question.