We are using a custom repository with RHEL 5.x. We were running into a ton of issues and conflicts when trying to run an update (issues with yum 32bit packages conflicting with x64 packages). To get around this, I added


to /etc/yum.conf. This worked great, until I had to install compat-libstdc++-296, which apparently is 32bit only. I checked on RH's site, and the only package listed verified that. So, when I try to specify the full package name compat-libstdc++-296.i386, the exclusion list blocks it from being installed.

Is there any way to force yum to temporarily ignore the exclusion list? Something like

yum install compat-libstdc++-296.i386 --ignore-exclude 

Not that it's hard to comment out the line, run the install, and then uncomment, my major concern is that we have around 300 servers this needs to be run on, and that's a lot of hands editing text files. I'd much prefer being able to copy and paste a command, if that makes sense.


From the yum man page:

       Disable  the excludes defined in your config files. Takes one of
       three options:
       all == disable all excludes
       main == disable excludes defined in [main] in yum.conf
       repoid == disable excludes defined for that repo
| improve this answer | |
  • Yup, just found this. I didn't check the yum man page, just the yum help text. It's less than helpful by stating: "--disableexcludes=[repo] disable exclude from main, for a repo or for everything". Thanks for providing the all flag, I appreciate it. – Matthew Aug 7 '13 at 17:48

I'd try to rpm -ivh install the file via URL. If that doesn't work because of dependency issues, try with the dependencies first.

| improve this answer | |
  • 1
    This would probably work in most cases, our scenario is awkward because we're using anycast, and don't have a real IP to send the HTTP request to. Good suggestion for most cases like I said though. – Matthew Aug 7 '13 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.