I have just set up a new Hyper-V 2012 Server and connected it to the domain. I attempted to follow the Microsoft documentation to allow remote management via server manager. I enabled remote management in the server configuration command menu.

I also allowed the server to respond to ping requests. When I search for the server in server manager from my windows 8 desktop it is found by name and added to the servers list. Under the manageability column I get the message "Target name resolution error." I'm able to ping the server by ip address but not by name. Both the server and my desktop are connected to the domain.

I tried adding the server name to my deskops hosts file in which case I can now ping the server by name but I still get the same error in server manager. The documentation simply states that I should have to enable remote management on the server, add any user accounts that should be allowed remote access to the local administrator group, and then connect to it from server manager.

I don't know if the documentation is incomplete or I may have something mis-configured?


I found the problem in my setup. It was indeed a miss-configured dns. This technet post led me to the problem: http://social.technet.microsoft.com/Forums/windowsserver/en-US/9f428e15-d3f6-499f-b263-d03cf009569c/w2k8-r2-ad-integrated-dns-nslookup-response-default-server-unknown-address-1 Running nslookup on the server showed that the dns server was unknown. When the dns role was configured by Active Directory the dns server address in the ipv6 properties was set to "::1". Un-checking ipv6 in the network adapter properties or configuring the ipv6 properties fixes the problem.


It sounds from the error description that you have a DNS problem. Is the DNS configured correctly on your Hyper-V host?

Both Host and Client should be able to resolve the opposite's IP address by name.

  • On the Hyper-V Server I set the dns server under network settings to the ip address of the domain controller. The server can ping my desktop by name. My desktop also has the domain controller set as the dns server. I cannot ping the server by name but the server manager is able to find the server by name when I initially add it. Only after adding the server to server manager do I get the target name resolution error. – esgeroth Aug 7 '13 at 21:57
  • I just re-installed the Hyper-V server and tested without joining it to the domain. I only changed the computer name and configured the server response to ping. I still cannot ping the server by name from any other non domain joined workstation. All other workstations can ping each other by name. In this test all computers are using the router for dns. – esgeroth Aug 8 '13 at 17:21
  • I seem to have made some small progress. I disabled the firewall and I was then able to ping the Hyper-V server by name. I re-enabled the firewall and I can still ping the server by name. I then joined the Hyper-V server to the domain and could no longer ping the Hyper-V server by name. I again disabled and re-enabled the firewall and I could then ping the Hyper-V server by name again. However, server manager still shows the same error. "Target name resolution error." – esgeroth Aug 8 '13 at 20:02
  • Is this a new domain you've set up or an existing domain in which DNS and DHCP are both confirmed to be configured correctly? – john Aug 9 '13 at 5:28
  • It is new. I assume that dns is working otherwise no computers would be able to join the domain as the domain name would not resolve. Dhcp is handled by the router. – esgeroth Aug 9 '13 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.