4

When installing an Application (as opposed to a Package/Program) during an OS deployment task sequence the only thing that seems to get written to the smsts.log if an install fails is that the application install failed, (normally with the seemingly unhelpful generic TS error code 0x80004005).

But in SCCM 2007 OSD, if you pressed F8 while the task sequence failed massage was onscreen, the smsts.log used to list the exact command line used to start an install, as well the return code and/or first few lines of any output from the installer as it exited.

It doesn't seem to do this in 2012. The closest equivalent to that in 2012 for Applications seems to be the AppEnforce.log, but none of the App*.log log files seem to exist during an OSD task sequence, they only appear later when task sequence has successfully completed (or if they do exist during the TS, I haven't managed to find them in the normal C:\_SMSTaskSequence\Logs or C:\Windows\CCM\Logs locations).

This is using SCCM 2012 SP1 installing a Windows 7 SP1 32-bit OS and related apps, if that makes any difference.

2

AppEnforce.log does exist during OSD, it depends what part of OSD you are running in when the error occurs. As you are installing applications I will assume you have already installed the client as part of the task sequence.

In this case your logs will be in %SystemRoot%\CCM\Logs, I have just forced a task sequence to fail installing an application and you can find it there. Failing that let the machine reboot after the failure and look in the normal location and you will find the logs in the normal place.

If the logs do not appear at all then this would suggest the application inforcement has not even started when the failure is thrown. In this case look for any errors in smsts.log for the step you are running. You will see an exit code, usually 24 (download failed) in the log file for the application install step.

  • Thanks a lot! I had VBSscript that did had no "On Error Resume Next" setup and cause the application to time out. By checking the Appenforce.log I got it fixed. – user256206 Nov 28 '14 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.