0

I just got Postfix 2.9.6 up and running on a Debian 7 Wheezy server and I can send and receive mail to the outside world but I'm unable to login to the SMTP server.

I've tried telnet, first by installing and starting inetd and verifying it is listening on port 23. I've also tried checking SMTP from web apps offered by wormly.com and pingability.com as well as others. All time out.

I also tried to telnet into my box on port 23 and likewise it will time out. From the same machine, I am able to telnet into Google's telnet server. I checked the firewall on my router and nothing is being blocked but I temporarily disabled the firewall anyway.

I thought maybe port 25 is being blocked at the ISP level but why wouldn't the free web clients work? Same thing with being able to telnet into Google's SMTP but not my own.

Any thoughts? Thanks.

  • 1
    Why do you keep mentioning port 23? – Michael Hampton Aug 11 '13 at 23:39
  • Google have a telnet server?! – Tom O'Connor Aug 11 '13 at 23:44
3

Things to check (while on the server) when you can't connect to a service (in no particular order):

  • Determine if the service is running

    ps aux|grep postfix

  • Determine if the service is listening on the proper address

    netstat -antup|grep 25

  • Determine if the service is blocked/allowed by the firewall

    iptables -L|grep 25

Other things to check:

  • Determine if the server is reachable

    ping IP_of_server traceroute IP_of_server

  • Determine if one of your other tools is blocking access (e.g., fail2ban)

  • Determine if the firewall on your client workstation blocking the traffic

  • Take a look at the routing table on both the server and your client workstation.

  • For the iptables line you may want to use iptables -L -n|grep 25 or iptables -L|grep smtp. And I would add telnet localhost 25 to the list of stuff to try on the server. – v154c1 Aug 12 '13 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.