1

this is what my ldap looks like :

  • red.lan
    • Groups(OU)
      • Computers(SubOU)
      • Printers(SubOU)
      • Users(SubOU)
    • Some(OU)
    • Users(OU)
      • SomeOther(SubOU)

So, i'm trying to make a query that would select all the groups in Users(SubOU), but not those in Groups(OU) nor any of the other subOUs of Groups(OU).

I already have a query that imports all users in Users(OU).

The actual query I have imports all groups in Groups(OU), and when i modify it, it imports the groups in Users(OU).

Query used :

ldap.synchronization.groupSearchBase=ou\=Groups,dc\=red,dc\=lan

The trick is that i have a OU named Users, and a subOU named Users too, which is why i'd like to specify that i want to import the groups of Users(SubOU) in the Groups(OU).

This query will then be used for Alfresco 4.2 (not sure it changes anything though.)

Thanks in advance !

Edit : I've tryed this query too :

ldap.synchronization.groupSearchBase=ou\=users(subou),ou\=Groups,dc\=red,dc\=lan‌​

It doesn't work either, as it imports all Groups in the Groups OU, and not only those in Users(subou) OU.

Edit 2 : There is no brackets in the names. The real names are as follow (but in french):

  • red.lan
    • Groupes
      • Ordinateurs
      • Imprimantes
      • Utilisateurs
        • *Administrations
        • General*
    • Services
    • Utilisateurs
      • Administrations

I put in italics the OU I want to be imported.

  • Why not just specify the exact DN of the Users(SubOU) part of the tree and be done with it? – Gagravarr Aug 12 '13 at 19:17
  • It seems to be taking the Users(OU) instead of the Users(SubOU), since they have the same name. But I'm not sure I'm specifying it the good way. How would you do it? – PaKempf Aug 13 '13 at 7:29
  • 2
    They don't have the same DN though! Try adding the Users(SubOU) onto your searchbase, with something like ldap.synchronization.groupSearchBase=ou=users(subou),ou\=Groups,dc\=red,dc\=lan – Gagravarr Aug 13 '13 at 9:11
  • I adapted the query as you said, but it imports all groups under the Groups OU, not only those under Users(Subou)... Advice ? :/ – PaKempf Aug 13 '13 at 11:31
  • The query posted in your question doesn't match what Gagravarr suggested. If you're using a different query, update the question to reflect what you're using to avoid confusion. – larsks Aug 13 '13 at 12:03
0

Okay, It seems you solved my problem : the trick was that Alfresco (the program using the query) is not automatically deleting the groups already created so I couln't see the difference.

Once manually deleting the groups, it comes out that the query only imports the requested groups.

Thanks for your time ! Issue solved !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.