1

I run "yum update" on my CentOS 6.4, but the Node.js package and dependencies fail with multiple errors like this:

Error unpacking rpm package nodejs-fstream-0.1.23-1.el6.noarch
error: unpacking of archive failed on file /usr/lib/node_modules/fstream/node_modules/graceful-fs: cpio: rename

... and so on for every package. Full output here http://pastebin.com/g8AprsNG

The package list is this (all from epel):

  • node-gyp | 0.10.6-1.el6
  • nodejs-boom | 0.4.2-2.el6
  • nodejs-fstream | 0.1.23-1.el6
  • nodejs-fstream-ignore | 0.0.7-1.el6
  • nodejs-fstream-npm | 0.1.5-1.el6
  • nodejs-glob | 3.2.3-1.el6
  • nodejs-hawk | 0.15.0-1.el6
  • nodejs-init-package-json | 0.0.10-1.el6
  • nodejs-npm-registry-client | 0.2.27-1.el6
  • nodejs-npmconf | 0.1.1-1.el6
  • nodejs-npmlog | 0.0.4-1.el6
  • nodejs-read-installed | 0.2.2-1.el6
  • nodejs-read-package-json | 1.1.0-2.el6
  • nodejs-request | 2.21.0-1.el6
  • nodejs-sntp | 0.2.4-1.el6
  • npm | 1.3.3-1.el6

There was no problem with the updates before.

I have read the answer on this question Broken dependencies on CentOS 6.4: can install nodejs but not npm but I have nodejs-ansi at version 0.2.0

0

Solved eventually by removing node completely and re-installing it from source.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.