When giving the command Enable-PSSRemoting with or without the -Force parameter this error occurs

Set-WSManQuickConfig : More data is available.
At line:50 char:33
+           Set-WSManQuickConfig <<<<  -force
+ CategoryInfo          : InvalidOperation: (:) [Set-WSManQuickConfig],
InvalidOperationException + FullyQualifiedErrorId : 

I've looked at this resource for help in solving this problem http://www.howtogeek.com/117192/how-to-run-powershell-commands-on-remote-computers/ and some others.

But it seems my solution is not in any of those. I have checked regarding run as administrationen, checked that the local admin is not disabled or have a blank password, also updated the registry key regarding the LocalAccountTokenFilterPolicy. Set the trustedhosts to *

This is done locally on a Windows Server 2008 R2 SP1, ENU x64

Result from: winrm quickconfig as suggest by @tony roth

Message = More data is available.
Error number:  -2147024662 0x800700EA
More data is available.

Result from: winrm enumerate winrm/config/listener

Address = *
Transport = HTTP
Port = 5985
Enabled = true
URLPrefix = wsman
ListeningOn = 10.108.x.x,, ::1, x:0:5ef5:79fb:6b:3590:f593:f4eb, x::5efe:, fe80::6b

:x:f593:f4eb%11, x::8418:7b59:e7ff:ccd4%12

Result from: dir WSMan:\localhost\shell

AllowRemoteShellAccess    true
IdleTimeout               180000
MaxConcurrentUsers        5
MaxShellRunTime           2147483647
MaxProcessesPerShell      15
MaxMemoryPerShellMB       150
MaxShellsPerUser          5

Result from: dir WSMan:\localhost\client

Name            Value                                        Type
----            -----                                        ----
NetworkDelayms            5000                               System.String
URLPrefix                 wsman                              System.String
AllowUnencrypted          false                              System.String
Auth                                                         Container
DefaultPorts                                                 Container
TrustedHosts              *                                  System.String

Result from: Get-Item WSMan:\localhost\Service\RootSDDL

Name     Value                                                        Type
----     -----                                                        ----
RootSDDL O:NSG:BAD:P(A;;GA;;;BA)S:P(AU;FA;GA;;;WD)(AU;SA;GWGX;;;WD)   System.String

Result from: Test-WsMan localhost

wsmid           : http://schemas.dmtf.org/wbem/wsman/identity/1/wsmanidentity.xsd
ProtocolVersion : http://schemas.dmtf.org/wbem/wsman/1/wsman.xsd
ProductVendor   : Microsoft Corporation
ProductVersion  : OS: 0.0.0 SP: 0.0 Stack: 2.0

This is locally on the server, the remote WORKGROUP clients is not yet involved in this scenario

  • run an elevated command prompt and run "winrm /quickconfig" it may give you a more descriptive error message.
    – tony roth
    Aug 14, 2013 at 13:35

3 Answers 3


Just ran into and solved this problem on a couple of systems. In this particular case, these two systems were not part of a domain, and the user account was not the original "Administrator" account, but rather a newer account that was also a member of the local Administrators group.

The solution came from the following blog post I wandered across: WinRM Access is Denied on Local Computer. In short, run the following from a command prompt (launched as Administrator):

> reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f

After that, re-launch the Powershell prompt as admin and re-run Enable-PSSRemoting. That simple.


Here's my trouble shooting guide to fixing this problem, it covers:

  • Is your machine connected to a domain or work group?
  • Are you logged in as a local Administrator?
  • Was PowerShell launched as 'Administrator'?
  • Is your password blank?
  • Are you trying to connect to a SharePoint farm?
  • Is your Server hosted/managed by a Hosting company?
  • Are you using VirtualBox?
  • Are you running the command on a computer where the language is not set to English?



I can totally reproduce this behavior on a fresh Windows Server 2008 R2 SP1 with PowerShell 2

Using an elevated PowerShell, enable-psremoting -force results in the Set-WSManQuickConfig : Access is denied. error.

The workaround that worked for me was to logon with the real 'administrator' account (S-1-5-...-500) and run the command again.

I don't know why this makes a difference, but it did for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.