0

I have an Apache VPS. When I'm testing my blog posts page loading times on Pindom tools, it shows long connecting (192ms), waiting (73ms), and receiving time (899ms). My some pages loading time goes to 15 seconds. Are there any way to minimize those times?

Apart from that I run Nginx Admin plug-in on this Apache VPS and its use cent OS. I have an Intel (R) Xeon (R) CPU E5620 @ 2.40GHz (2 priority and 8+ CPUs) with 1.5 GB RAM. Daily visitors 2,500-3,500 with 4,00-5,500 page preview. This VPS has only a one wordpress blog.

What are the settings that I should use to optimize these things?

My some Apache configurations.

Timeout 300
TraceEnable Off
ServerSignature Off
ServerTokens ProductOnly
FileETag None
StartServers 5

MinSpareServers 5
MaxSpareServers 10

ServerLimit 256
MaxClients 150
MaxRequestsPerChild 1000
KeepAlive On
KeepAliveTimeout 5
MaxKeepAliveRequests 100

RewriteEngine on
RewriteMap LeechProtect prg:/usr/local/cpanel/bin/leechprotect
RewriteLock /usr/local/apache/logs/rewrite_lock


UserDir public_html


UserDir disabled

Any help really appreciate.

Thanks!

  • make sure HostnameLookups Off are off as well – Doon Aug 16 '13 at 16:47
  • It sounds like a network issue...do you have any other things you can test? Like say, a very basic website? File download? – Nathan C Aug 16 '13 at 17:31
  • the other thing it could be is Crappy VPS provider. Since it is by nature shared. It could be everything else is overloaded . – Doon Aug 16 '13 at 19:04
0

With that kind of workload Apache hardly is the component to blame. Apache is the pizza delivery guy who gets blamed about the slow delivery times, even if the real reason is that the cook was very slow.

So, time to look elsewhere. Does you WP installation have any exotic 3rd party plugins? Does it load resources from some external resources (say, does it have Facebook like/comment possibility or something else)? Is the VPS you use overloaded by the other customers? How about the database server, is it located at your VPS installation or is it somewhere else? Or the network connection? If you load some static content there, like a big .tar.gz file, is the download snappy and reliable?

Though if you truly want to tune Apache, start with lowering the Timeout value to something more reasonable, like 10 or 5 seconds.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.