1

After updating the static DNS settings on our Cisco WRVS4400N router, approx 1/3 of stations did not receive the new DNS settings. On the stations that did not receive the new settings,

ipconfig /all

still shows the old DNS settings.

Network has approx 15 workstations. Mix is half/half Windows 7 Home Premium / Windows 7 Professional.

There is no relationship between the Windows version and which workstations are not getting the new DNS settings. (Stations that received the new settings did so immediately, without rebooting)

There is no relationship between stations rebooting and receiving the new DNS settings.

I have tried:

  • rebooting
  • ipconfig /flushdns
  • ipconfig /release and then /renew -- however, received message to the effect that "no adapters are in a state to respond" to those commands.

Suggestions? Ideas? Insights? Things to try?

  • When does the lease expire on the stations that haven't updated ? – user9517 Aug 16 '13 at 21:58
6

DHCP options like new DNS servers are only applied when the lease is renewed. On Windows this happens at specific times:

  • Halfway through the current lease

  • When you run manually release and renew a lease using ipconfig /release followed by ipconfig /renew

The most likely explanation is that these computers have leases that were more current than their counterparts, so the lease hasn't been renewed yet.

  • Yes, but rebooting the computer did not fix the situation. Thanks, though, for jolting my memory: ipconfig release/renew returned a note that no adapters were in a state to respond to those commands. I'll add that to the OP. – cssyphus Aug 16 '13 at 22:18
  • If network settings are set to automatic - it should. – GioMac Aug 17 '13 at 0:13
0

It turns out there were three stations (legacy) with static IPs. It is not possible to specify a static IP without also hard-coding the DNS entries, and that was the problem.

The lease expiry issue was something I hadn't considered, and that was very helpful -- in fact, it was ultimately what lead me to discover the correct answer (so +1). But when the DNS settings hadn't changed by Monday morning, I checked for a hard-coded IP and sure enough...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.