I have this directory which I cannot remove the read only attribute from. The computer is running XP SP2 (or SP3, not sure) and the directory sits in a NTFS file system.

Looking into the web I found this: http://support.microsoft.com/kb/256614 which tells that if the directory is "customized" it's treated as a system folder and thus "read only".

I don't think this is a scenario in my case, but anyway it's not helping, their recommendation is more or less:

attr -r -s /d /s d:\data

and this is not working for me. Any other ideas?

More info: The directory is served to an HTTP server (wamp) and the directory is an SVN check out. What happens is that the web server cannot write files into the directory (imagechace from drupal is you are really interested).

Edit 2:
The original post claimed that the directory sits on a VFAT FS, however I booted Fedora 11 from livecd and the partition is marked as NTFS.

Edit 3: I left the company which I worked on, on which this situation happened... so I cannot fully close this question. But things get even worse: I tested the "attr -r" answer I put, it did not work for me, and now the developer said that it worked for her. A nice WTF moment. Probably a reboot helped...

Sorry for loosing details. If anyone has the same problem, and one of the answers helps him - please comment.


Take ownership of the folder then you should be able to remove the read-only attribute.

  • +1 I have generally found that this ALWAYS fixes the issue described in OP. – GregD Feb 7 '11 at 23:13

Every now and then I see this on machines that have XP Pro SP2 or higher installed on an NTFS partition and are not part of a domain. If the machine is not part of a domain, you will need to add a FAT32 partition, move the read-only folder to it, remove the read-only attribute, and set your HTTP server to use the folder from the FAT32 partition.


There is no such thing as a read only folder in Windows(except with ntfs permissions). The read only attribute you have if you use attr or check the folder properties does not actually apply to the folder and it will always display as marked(filled square). The read only attribute is applied to the files within the folder.

What is the reason that you are trying to perform this action? Is it possible that you're trying to achieve something else?

  • That's exactly what I am seeing a filled square. I am running a WAMP from that dir (which is an SVN checkout) and the web server cannot write files into it. The web server is running as administrator. – elcuco Aug 12 '09 at 13:37
  • Since you're not running this on an ntfs partition I would guess that your problem is related to your php/apache config. It's probably not allowing writes to the directory. – Paxxi Aug 12 '09 at 15:00

Is booting outside of xp an option - as its not NTFS you should be able to see it with a normal boot disk without needing anyfancy stuff. Then just navigate and do this manually?


For NTFS the rights come under the security tag of properties not the read only attribute on the general tab. If you do not have the correct permissions for the file/folder then you won't be able to change the read only attribute.


there is simply some steps to resolve your problem:

  1. folder option
  2. view tab
  3. in advance settings uncheck "simple file sharing(recommanded)
  4. go to the specific folder
  5. R-Click on it
  6. properties
  7. security tab
  8. advance tab
  9. owner tab
  10. select your account name
  11. check "replace ............objects"
  12. error appears click yes
  13. and remove the attribute and enjoy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.