It's a Hyper-V machine that runs the DC for my lab environment. Had a power failure that shut down my server and all other machines come up fine except this lone DC. It boots up straight to Recovery.

Startup Repair hasnt helped. When I go into DISKPART, it shows that the C drive is System Reserved and the Windows parition is actually assigned letter D for some reason. I tried changing this around but upon reboot, the drive letters are back to the problematic state.

Also tried deleting the System Reserved volume, then assigning letter C to the Windows drive, but upon reboot, the old settings came back up again.

Have also tried StartRep.exe from the boot disk, BCD repair, etc. Any thoughts on how to get the DISKPART letter assignments to "stick"? I think that may be the road block to getting the server back up

  • 1
    Are you using UEFI to boot? In that case your C:\ is the actual UEFI boot files and D:\ is the system drive. In that case try BCDboot C:\Windows /s C: /v – TheFiddlerWins Aug 19 '13 at 15:01
  • I have UEFI on the host server but nothing of the sort for the VM. – Agent Aug 19 '13 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.