0

I'm running mysqltuner to tune up my database and I'm running into a very strange occurrence.

Even though the entire database is MyISAM (all tables) it says the following:

[!!] InnoDB data size / buffer pool: 403.1M/128.0M

The default storage engine of the database was InnoDB (even though all tables are MyISAM) so I thought that might be causing the problem somehow but when I changed the default-storage-engine value to MyISAM I still see the same exact InnoDB-related warning in mysqltuner.

So why is this happening and how do I fix it? I'd rather not waste 400M on InnoDB's buffer pool when I'm not using InnoDB to begin with.

Note: What I am NOT trying to do here is discuss the age-old question of MyISAM VS InnoDB, I just need to figure out why InnoDB is eating my resources even though I'm not using it.

1

InnoDB uses only 128.0M of memory, the rest is read without buffer when needed. This won't cause any problems. MySQL won't use buffer/cache parts for InnoDB without need, so, if you don't have anything in InnoDB format - you have nothing to worry about.

You can competely disable InnoDB with by adding skip-innodb in my.cnf in section [mysqld].

  • Well, actually, I was being stupid, and information_schema tables are InnoDB. I was only checking my own tables. Now, do you think I should do what mysqltuner says and increase the InnoDB buffer pool? Is it important for performance? – robert Aug 20 '13 at 8:03
  • No, it, won't affect anything - these tables are for information needs (MEMORY). – GioMac Aug 20 '13 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.