i want to manage my Windows Server 2012 remotly via Server Manager and the MySQL installation via MySQL Workbench 6.

Now i got serval problems. The first one is that i cant get remote WMI access to my server. Everytime i try to connect with the "Paessler WMI Tester" the error message is "Port Error 135: RPC Server not accessible". The Ports are open on the server, and the service is runnig. I even tried to turn the Firewall off, but no success.

Server OS : Windows Server 2012 Datacenter Edition Desktop OS : Windows 8 Pro


  • Is UAC enabled on the Server? – Zapto Aug 21 '13 at 11:40
  • I disabled UAC long before – Alex Aug 21 '13 at 11:59
  • No. The server and my computer are not in the same domain. Which credentials i had to provide except username, password, and the ip ? – Alex Aug 21 '13 at 12:14

First off, Paessler WMI Tester sounds useless, so I would recommend uninstalling it. Server 2012 already has a veritable cornucopia of WMI tools that it ships with, so there's no need to install yet another "WMI tester."

Consider the following, from your Win8 desktop:

PS C:\> $Options = New-CimSessionOption -Protocol Dcom
PS C:\> $CimSession = New-CimSession -ComputerName 'Server2012' -SessionOption $Options
PS C:\> Get-CimInstance -CimSession $CimSession -ClassName Win32_OperatingSystem

Add whatever you need to those options, such as credentials with which to access your server, if needed. If your server and your workstation are in separate domains or if you're running Powershell from an unprivileged account, you will need credentials.

You shouldn't even need to get that fancy.

PS C:\> Get-CimInstance -ComputerName 'Server2012' -ClassName Win32_OperatingSystem

Should be sufficient. The first example is more complex, but is capable of targeting down-level machines that do not even have Powershell installed. Which your Server 2012 machine does. Powershell Remoting is turned on by default in Server 2012. But that's another topic...

If you are still getting RPC Unavailable errors, try simply telnet server2012 135 ... does that telnet work? If it fails, then you are looking at a firewall problem.

  • Okay i first tried the telnet connection. "Could not connect to the host, on port 135: Connection error" but if i cannect via remote desktop and go to canyouseeme.org and put there 135 he says that the Port is open. The firewall is turned off ! – Alex Aug 21 '13 at 12:23
  • If you can't telnet to port 135 from where you are, and the remote machine is definitely listening on that port with a TCP service (which it should be, the RPC Endpoint Mapper,) then there's some network-layer problem between you and the server. E.g. a firewall. Since your workstation can't reach it, yet, a website on the internet can, perhaps your egress firewall (maybe your ISP's firewall) is blocking your outbound traffic on 135? Also I would strongly recommend against exposing the RPC EPM to the internet. – Ryan Ries Aug 21 '13 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.