0

The basic configuration is a CentOS machine running rp-pppoe and a separate router, both connected to a DSL modem through a simple switch. Each device has it's own separate PAP id/password.

This configuration has worked fine for years, until the linux machine was replaced and a new version of rp-pppoe installed. Now what seems to happen is that when the router tries to authenticate, the centos machine responds instead and replies it does not have the password for the provided account. Connecting the router directly to the modem to allow it to authenticate, then quickly plugging it back into the switch temporally alleviates the problem.

pppoe-server[26658]: Session 40 created for client 00:17:c5:14:0a:b9 (10.67.15.40) on eth0 using Service-Name ''
pppd[26658]: pppd 2.4.5 started by admin, uid 0
pppd[26658]: Using interface ppp1
pppd[26658]: Connect: ppp1 <--> /dev/pts/3
pppd[26658]: no PAP secret found for user@host.net
pppd[26658]: PAP peer authentication failed for user@host.net
pppd[26658]: Connection terminated.

My question is is this a problem with rp-pppoe/its configuration or an inherent problem in my setup?

  • could you post the relevant config files from /etc/ppp (likely pppoe-server-options). Does it contain login or require-pap/require-chap directives? – the-wabbit Aug 22 '13 at 6:21
  • Here is the contents of the file: require-pap login lcp-echo-interval 10 lcp-echo-failure 2 – Illuyankas Aug 22 '13 at 18:18
0

rp-pppoe employs pppd and supplies the options provided in /etc/ppp/pppoe-server-options. From man pppd:

login

Use the system password database for authenticating the peer using PAP

[...]

require-pap

Require the peer to authenticate itself using PAP

So you should care to remove the login and require-pap directives from your config files - they are not needed to perform a dialup but result in a PPPoE "server" setup on your CentOS box.

  • Hm odd that they are set like that by default then. I will try it when I can get back there and post an update. Thanks! – Illuyankas Aug 27 '13 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.