4

Server 2008 R2 SP1, with Remote Desktop Services.

Office 2013.

[Edit: Most] Microsoft updates installed.

Publish Outlook as a RemoteApp, and run it from a Windows 8 client, then open an email. What happens is this:

Outlook graphical glitch

  • The email opens and renders briefly, but the Outlook inbox becomes partly-visible through the email.
  • Most of the email is invisible, as if it was in the background, except the border remains visible like an embossed imprint.
  • The partly-invisible email is actually in the foreground, the visible Outlook main window is in the background.

Moving things around, clicking on them, causing a refresh, fixes the display. Sometimes waiting does. It happens pretty much every email, but not exactly every one.

Disabling hardware acceleration in the Outlook options doesn't make a difference, nor does disabling add-ins, nor does changing the LoadBehaviour in the add-in registry entries.

Using a full remote desktop session, Outlook works fine.

It happens on multiple Windows 8 clients, too. Not sure about Win 7.

Any ideas, please?

[Edit: Disabling themes, menu animations, bitmap cache persistance, font smoothing, etc. in the RDP connection - all make no difference].

[Edit: Also tried: - Disabling desktop composition, and menu/window animations on the server - Running Outlook in 'safe' mode (with Outlook.exe /safe) - Changing Outlook theme - Connecting to my PC using RDP, then opening the remote app, to try and get around it being my video drivers. - The latest round of Windows/Office updates on the servers. - Removing/recreating my RDS User Profile.

All no change.

Tried on 3x Windows 8 PCs, all exhibit this behavior. Tried on 3x Win 7 PCs, only one does this, the other two appear OK.

]

  • Do all of the Win8 clients have the same graphics card / driver set? If so, it might be worth testing a differing one. I strongly suspect this to be the client's problem. – the-wabbit Aug 22 '13 at 15:57
  • Nope, I have Radeon 4000/5000 series, the other main one has an ATI FireGL, and I've just watched it happen on a Windows 8 / nVidia client and a Win 7 nVidia client. – TessellatingHeckler Aug 22 '13 at 16:16
  • Added updates in an edit. – TessellatingHeckler Aug 23 '13 at 21:02
  • There is a hotfix for a problem which sound remotely related. Check out support.microsoft.com/kb/981156/en-us and see if it helps matters. – the-wabbit Aug 23 '13 at 21:37
1

A post in the Microsoft Partner Support Forum did yield these two possible approaches:

  1. enable RDP 8.0 via the update 2592687
  2. install the hotfix from KB2786923

but none seemed to ultimately fix the specific issue, yet they might be worth trying.

  • This is probably more of a comment than an answer. – Drew Khoury Sep 2 '13 at 10:22
  • I can't see your post, as I have no login that works. Did you get any answers that helped? – TessellatingHeckler Oct 2 '13 at 19:27
  • @TessellatingHeckler check out the post's update – the-wabbit Nov 19 '13 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.