8

I am running Windows 8 64bit and running Hyper-V VM's. On my host machine I want to map a drive to the VM using the following command.

net use * \\10.10.18.104\c$
Drive Y: is now connected to \\10.10.18.104\c$.

When I look in File Explore I don't see a Y: drive.

However, in the command window I can change directories using these commands.

Y:
dir

and all the files are displayed. Why does this not show up in File Explorer?

This seems to be intermittent as some days the drive does show up in File Explorer.

Thanks for the help

2
  • Typically explorer is a bit sluggish with drive mounts (especially on cluttered systems, I always imagined a refresh thread is hanging somewhere) and what helps is <key>F5<key> refresh on the My Computer view. – eckes Apr 21 '17 at 14:39
  • Just refreshing with F5 did not help - however, restarting the explorer.exe did. So, I enabled “launch folder windows in a separate process” in the Explorer options. Tread carefully, though - this may cause unwanted side-effects. – chaosflaws Jan 16 '19 at 15:28
16

I'm going to venture a guess that you're running the command prompt as another user or as "Administrator" and you have UAC enabled. When this happens, you've mapped the drive under a different user context than the one your Explorer window is running in. Launch a command prompt without doing Run As Administrator or Run As a Different User and you should be fine.

0

Turn on Network Discovery. This can be done by opening "Network and Sharing Center", then click "Change advanced sharing settings", then select the radio button for "Turn on Network Discovery" under the appropriate profile.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.