On our Windows Server 2003 we host a MS-Access application (*.mdb), the users today were complaining that when they copied anything to the clipboard either to or from the RDP window, the clipboard was not being transferred. Most of our users are using Windows 7 64-bit.

I tried the usual killing of the rdpclip.exe process and restarting it, but this didn't fix the problem. The issue occurred when I logged into the system via RDP myself on my local machine.

I gave up and decided to restart the server. But as I kicked the users off I logged back in and tried it again, the problem seems to have gone away. Is there anything other than rdpclip that could prevent people's clipboards from being used?

  • P.S. It is a little low on disk space. – leeand00 Aug 22 '13 at 19:00

The RDP clipboard in Windows Server 2003 is notoriously unstable. Rebooting the server is the only "real" fix. If you want a more stable and reliable RDP clipboard then upgrade to Windows Server 2008 or Windows 2008 R2, both of which have significant changes and improvements to the RDP clipboard.

| improve this answer | |
  • I've never had this happen before today. – leeand00 Aug 22 '13 at 19:47
  • Understood. I manage a W2K3 TS farm for about 400 users and I see it all of the time. – joeqwerty Aug 22 '13 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.