I just installed iRedMail on Ubuntu 12.04 lts, fresh install following the tutorial on their website. Everything functions well, including webmail, however sending mail over smtp (port 465) doesn't work at all and I also cannot telnet to the server on that port.

Here's the result of nmap:

rDNS record for xx.xx.xx.xx: xxxxxxxx
Not shown: 991 closed ports
22/tcp  open  ssh
25/tcp  open  smtp
80/tcp  open  http
110/tcp open  pop3
143/tcp open  imap
443/tcp open  https
587/tcp open  submission
993/tcp open  imaps
995/tcp open  pop3s

I tried telling postfix to restart in the hope that smtp would appear on the above but no such luck.

Does anyone with more experience with this have any ideas? Thanks in advance.

edit: Note i have removed iptables for now so that can't be the issue.


As far as I know, iRedMail is used postfix as MTA. So you can see does the smtps is enabled in master.cf. It should be something like

smtps     inet  n       -       n       -       -       smtpd
  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o milter_macro_daemon_name=ORIGINATING
  • I have those lines in that file but they have #'s at the start, should they be removed? link: pastebin.com/TkQkuUKf @alex – damnyouiredmail Aug 25 '13 at 13:20
  • Yes, you need to remove # from these lines and restart the postfix – ALex_hha Aug 25 '13 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.