I am using a Linux server to perform my simulations. The login and the file-system of the server are protected using kerberos. The file-system is supported using NFS.

Since my simulations take a lot of time to run, my ssh sessions used to hang regularly. So, I have started running my simulations in byobu (similar to screen).

In order to make sure that my kerberos session remains active, I am using the krenew command.

I have entered the following command in my .bash_profile file. (I am sure that it is called for every login)

killall -9 krenew 2> /dev/null
krenew -b -t -K 10

So everytime I ssh to the server, I kill the existing krenew command. Then, I spawn a new krenew command -b (which runs in background), -t (I forgot why I was using this option !), and -K 10 (It must run after every 10 minutes and refresh the kerberos cache).

When I run the simulations, It runs for 14 hours and then suddenly, I am getting error for reading file Permission Denied

Is the command that I am running incorrect ??

  • You really need automatic ticket renewal. Contact your system administrator. Aug 26 '13 at 15:10
  • What is the max renewal time of a ticket? Would k5start be a better option? It usually comes in the same package.
    – 84104
    Aug 26 '13 at 20:03
  • @MichaelHampton I am the system administrator. What should the system administrator do in this case ?? I am not overly bothered about security. My main aim is to get my script running. Aug 30 '13 at 7:23
  • @84104 What is the primary difference between k5start and krenew ?? I guess both the programs are renewing tickets only right ?? Aug 30 '13 at 7:24
  • @prathmesh.kallurkar man k5start
    – 84104
    Aug 30 '13 at 15:57

You might not be getting renewable tickets by default. Check the flags on the ticket using

klist -f ( MIT )


klist -v ( Hiemdal )

if you don't have renewable or R in the flags, use the -r option to kinit to get a renewable ticket. If you are getting a renewable ticket, it's more than likely that you aren't renewing the same ticket every time.

On linux kerberos tickets are files in /tmp and every login session gets a different file. I'd suggest you use kstart instead to start your job with it's own ticket and a daemon to manage that ticket.

  • It is showing a R flag. The flags are : FPRT. I have actually found a hack for this solution. I use script in my client machine logs into the server machine every 20 minutes using sshpass tool. However, I would still prefer a cleaner solution for kerberos. Nov 18 '13 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.