CentOS | Windows 2008

I've got a CentOS 5.5 server running nfsd. On the Windows side, I'm running Windows Server 2008 R2 Enterprise. I have the "Files Services" server role enabled and both Client for NFS and Server for NFS are on.

I'm able to successfully connect/mount to the CentOS NFS share from other linux systems but am experiencing errors connecting to it from Windows. When I try to connect, I get the following:

C:\Users\fooadmin>mount -o anon z:
Network Error - 53

Type 'NET HELPMSG 53' for more information.

(IP and share name have been changed to protect the innocent :-) )

Additional information:

  • I've verified low-level network connectivity between the Windows client and the NFS server with telnet (to the NFS on TCP/2049) so I know the port is open. I've further confirmed that inbound and outbound firewall ports are present and enabled.
  • I came across a Microsoft tech note that suggested changing the "Provider Order" so "NFS Network" is above other items like Microsoft Windows Network. I changed this and restarted the NFS client - no luck.
  • I've confirmed that the share folder on the NFS server is readable/writable by all (777)
  • I've tried other variations of the mount command like: mount z: and mount z: and mount -o anon mtype=hard \\ * No luck.
  • As per the command output, I tried typing NET HELPMSG 53 but that doesn't tell me much. Just "The network path was not found".

I'm lost on how to proceed with troubleshooting. Any ideas?

1 Answer 1


I have the same problem and I found a post here saying:

NFS server has an option of working in insecure mode (Allowing higher incoming port numbers). Windows NFS client often uses higher port numbers. You can enable this option by adding an option to the share Example: /share *(insecure,rw)

You can also try installing Windows services for UNIX package which contains a nfs client. You can try to connect the nfs server using this utility and cross check again. You can download the package from the following link http://www.microsoft.com/downloads/e...displayLang=en

I changed the /etc/exports according to it (by adding the insecure option) and it works. Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .