I have problem with full text search for one application.

I cannot search for dates for a field that is defined as date/time. The full text search dialog for Condition "By field" and the field in question give us the option "contains/does not contain" when we instead want the search options "is on/is after" etc.

-> delete and re-create FTI does not work

-> run off line copy style compact

-> Creating local new copy (design and documents), and creating full text index, will enable searching by date for this field.

-> but this does not work on production server

Any ideas?

  • Other problem could be, that there is still a document with this Datetime field set as Text in your application. – umeli Jan 13 '14 at 9:21

It sounds like an issue with the UNK table. The field was probably not created as a date/time field in the first place. Delete the FT index, do an offline compact, and re-build the FT index.

See http://www-01.ibm.com/support/docview.wss?uid=swg21261002 for more info.

  • -> delete the index and delete the associated FT directory then run compact -D on it and recreate the index solved the problem Title: How to Delete and Create the Full Text Index Doc #: 1092508 URL: ibm.com/support/docview.wss?uid=swg21092508 this actually solved the problem – kasper_341 Aug 30 '13 at 9:36
  • but now i have run into another problem #2 it possible to search the field as a Date/Time field, but the search options are still "contains/does not contain" any ideas ? thanks for your help – kasper_341 Aug 30 '13 at 9:39
  • It sounds like the UNK table hasn't been re-built. Did you run the compact offline using ncompact? Where do you see that the field is now a Date/Time field? – Per Henrik Lausten Aug 30 '13 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.