0

I'm currently running Hyper-V in Windows Server 2012, and I'm trying to get a Debian Wheezy VM running. I've configured the virtual switch and added a legacy network adapter configured to the virtual switch, and removed the regular network adapter that was automatically added by Hyper-V.

When autoconfiguring the network during installation, I'm getting "Network autoconfiguration failed". So, I tried to set it up manually, with the same settings that I can see when I use ipconfig /all in Windows. However, with this, I'm getting "Unreachable gateway". Any ideas as to why this is happening?

Just some background info: I currently have 3 IPs for my server, one primary IP and I have set-up two additional IPs in the Virtual Switch's IPv4 advanced configuration. They seem to work, because I can ping the additional IPs. I'm trying to set one of these additional IPs as the IP of my Debian installation.

  • 1. Where do you configure an ip address on the Virtual Switch? 2. You need to assign an ip address to the VM, not the Virtual Switch. 3. The Virtual Switch is not a firewall or a NAT device for the VM's. – joeqwerty Aug 28 '13 at 21:19
  • I assigned the IPs to the Virtual Switch in the adapter settings in the Network Center. How do I set an IP to an individual VM? I've tried googling for that too, but I couldn't find much of any info. – Deniz Zoeteman Aug 28 '13 at 21:21
  • Ok. That's not really assigning an ip address. That's assigning an ip address to the physical NIC that the Virtual Switch is bound to. So that physical NIC has those ip addresses but the Virtual Switch doesn't have those ip addresses. You assign an ip address to a VM the same way you would in a physical machine. So however you assign an ip address to a physical install of Debian Wheezy is how you should assign an ip address to your virtual Debian Wheezy. – joeqwerty Aug 28 '13 at 21:34
0

OK. That's not really assigning an ip address to the Virtual Switch. That's assigning an ip address to the physical NIC that the Virtual Switch is bound to.

So the physical NIC has those ip addresses but the Virtual Switch doesn't have those ip addresses.

You assign an ip address to a VM the same way you would in a physical machine. So however you assign an ip address to a physical install of Debian Wheezy is how you should assign an ip address to your virtual Debian Wheezy.

| improve this answer | |
  • That's exactly what I'm trying though - setting up a IP to Debian. I'm trying to do this during installation, but I'm getting the "Unreachable Gateway" error. – Deniz Zoeteman Aug 28 '13 at 21:36
  • First remove those ip addresses from the physical NIC. Then make sure that your Virtual Switch is an External Virtual Switch. Then make sure that the ip address, subnet mask, DNS servers, and Default Gateway in Debian is correct. – joeqwerty Aug 28 '13 at 21:38
  • I removed the IP addresses, and yes, the Virtual switch is an external one. I've double checked the IP/subnet/gateway settings too, but it's giving me the same error. – Deniz Zoeteman Aug 28 '13 at 21:46
  • It's recommended to use a legacy network adapter only for the purpose of performing a network based install of the OS in a VM. Remove the legacy network adapter and add a "standard" network adapter. Assign the appropriate ip settings and see what happens. Also, did you have the Hyper-V Integration Services installed in the VM? – joeqwerty Aug 28 '13 at 21:49
  • Yeah - I saw the legacy network adapter settings in the guide for Hyper-V provided by the Debian website. I now set it to a regular adapter, but it's still not functioning. And no, I have not installed it - there's no OS on the VM yet, and when I insert the Setup Disk it just gives a boot failure (I'm guessing you need an OS installed to install the Integration Services) – Deniz Zoeteman Aug 28 '13 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.