I've run below shell command as per ZeroMQ website to install PHP-ZMQ:

sudo pear channel-discover pear.zero.mq
sudo pecl install pear.zero.mq/zmq-beta

Below are traces for the installation:

downloading zmq-1.0.6.tgz ...
Starting to download zmq-1.0.6.tgz (23,880 bytes)
........done: 23,880 bytes
10 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
building in /var/tmp/pear-build-rootwCcLwT/zmq-1.0.6
running: /var/tmp/zmq/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-redhat-linux-gnu
checking host system type... x86_64-redhat-linux-gnu
checking target system type... x86_64-redhat-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib
checking for PHP extension directory... /usr/lib64/php/modules
checking for PHP installed headers prefix... /usr/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking whether to enable 0MQ support... yes, shared
checking for pkg-config... /usr/bin/pkg-config
checking libzmq installation... configure: error: Unable to find libzmq installation
ERROR: `/var/tmp/zmq/configure' failed

I already have libzmq installed via Yum in my CentOS 5 server.

I can also confirm by running below

yum install zeromq

and traces below:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.site.net.au
 * extras: mirror.site.net.au
 * updates: mirror.site.net.au
Setting up Install Process
Package zeromq-3.2.2-13.1.x86_64 already installed and latest version
Package zeromq-3.2.2-13.1.i386 already installed and latest version
Nothing to do

So I have libzmq installed so I don't see why PHP-ZMQ is throwing error at the installation.

What would be the cause for this?


You need the development files. I'd wager they're called zeromq-devel or something of that sort on RPM based distributions.


Installing CZMQ via brew solved this for me.

  • 1
    Could you elaborate more on your answer, e.g. describing what CZMQ is and how installing that can fix/address the OP's issue?
    – Castaglia
    Mar 9 '16 at 22:26

For any future guy with this trouble - I did try this as instructed from this ZeroMQ - sudo pecl install zmq-beta in my Mac. Then I did try as instructed by @Tinus Guichelaar - brew install czmq. It worked after lots of failed solutions!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.