10

I Have Dell OPTIPLEX 755 machine with VT enabled in BIOS but when i trying to check using KVM i am getting following error

I am missing something?

root@nova-controller:~# kvm-ok
INFO: /dev/kvm does not exist
HINT:   sudo modprobe kvm_intel
INFO: Your CPU supports KVM extensions
INFO: KVM (vmx) is disabled by your BIOS
HINT: Enter your BIOS setup and enable Virtualization Technology (VT),
      and then hard poweroff/poweron your system
KVM acceleration can NOT be used
root@nova-controller:~#

UPDATE:

root@nova-controller:~# sudo modprobe kvm_intel
FATAL: Error inserting kvm_intel (/lib/modules/3.2.0-26-generic/kernel/arch/x86/kvm/kvm-intel.ko): Operation not supported

dmesg

[   57.887352] kvm: disable TXT in the BIOS or activate TXT before enabling KVM
[   57.887354] kvm: disabled by bios
[   61.199353] kvm: disable TXT in the BIOS or activate TXT before enabling KVM
[   61.199355] kvm: disabled by bios
[  965.566334] kvm: disable TXT in the BIOS or activate TXT before enabling KVM
[  965.566337] kvm: disabled by bios
4
  • What happens when you do the sudo modprobe kvm_intel. dmesg should show some messages.
    – Nathan C
    Aug 29, 2013 at 19:09
  • 2
    Make sure you did what it said: physically power off the computer and power it back on. Aug 29, 2013 at 19:11
  • @NathanC - I have updated question with command output
    – Satish
    Aug 29, 2013 at 19:16
  • @MichaelHampton - I have shutdown box removed power cable for 1 min and reboot again
    – Satish
    Aug 29, 2013 at 19:17

1 Answer 1

14
+50

In your BIOS you should have the following settings:

  • Security: Execute Disable should be On
  • Performance: Virtualization should be On
  • Performance: VT for Direct I/O Access should be On
  • Performance: Trusted Execution should be Off

After changing these and saving the settings, physically power off the computer and power it back on.

3
  • 1
    Holy Moly!! You guys are super awesome!!! Trusted Execution should be Off did magic!!
    – Satish
    Aug 29, 2013 at 19:28
  • 1
    The same worked when VirtualBox reported that VT-x was disabled in the BIOS even though it was definitely enabled.
    – Agrajag9
    Oct 7, 2014 at 15:47
  • This is what worked for me on Dell Precision M2400. I can't stress enough how useful this answer is. Please everyone if you find this useful vote UP. I had very strange problems with networking (freezing on ssh connection) on using vagrant with virtualbox. This solved it for me. Thank you very much. Mar 17, 2020 at 20:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .