2

I just installed Debian Wheezy 7.1.0 on an Intel vPro System (Intel Core i5-2520M, SuperMicro MBD-X9SCV-Q-O). Intel AMT's KVM works perfectly until Debian has completed booting and shows the login prompt. At this point, the screen in RealVNC goes blank and after a minute, it dies with the following error message:

Error 0x80862000: Unsupported or inactive display adapter

Before it dies, while the screen is already blank, I can type my login info, and if I then type reboot, the server restarts. So, Debian is actually running as expected, just the display isn't working.

The system does not have any additional video cards installed, only the CPU-integrated one.

Here is what I think is going on: Debian detects that there is no monitor connected to the video card and then decides to switch the video card off to save energy (maybe some sort of headless mode). This in turn makes it impossible for Intel AMT to provide the frame buffer.

Assuming my assessment is right (otherwise please correct me), I am trying to figure out the following:

Is there a way (preferably a boot-time kernel option) to tell Debian to keep the video card enabled even if there is no monitor connected?

5
  • What's logged on the Debian system? Aug 29 '13 at 19:41
  • @MichaelHampton I don't have a monitor connected to it right now, so it's hard to check, but given that I can interact with it completely normally (issue a reboot for example), except for not seeing its video output, I would assume that it doesn't show anything out of the ordinary... But, if I find a way to tell it to keep the video card on and it still doesn't work then, then I will go and see if I can drag a monitor over there to check the logs.
    – Markus A.
    Aug 29 '13 at 19:43
  • You have to know what the problem is first, before you can solve it! Aug 29 '13 at 19:48
  • @MichaelHampton I realize that, but after some googeling, I think I understand what the problem is. I may be wrong, of course, but I would like to test that with the answer to the question in bold. Of course, if someone has had this same issue and knows a different solution, that would be great, too.
    – Markus A.
    Aug 29 '13 at 19:59
  • @MichaelHampton Looks like I was one the right track... I found the solution... See below.
    – Markus A.
    Aug 29 '13 at 21:54
4

I found the following way to fix the issue:

  1. When grub shows the kernel boot choices, press e to edit the current boot entry.
  2. Find the line that looks something like this:

    linux /boot/vmlinux-... root=... ro quiet
    
  3. Add nomodeset to the end of this line, so it looks something like this:

    linux /boot/vmlinux-... root=... ro quiet nomodeset
    
  4. Press F10 to boot this configuration and everything should work fine for this boot
  5. To make this permanent, use your favorite text editor as root to open /etc/default/grub
  6. Find the line that looks something like this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    
  7. Add nomodeset to this line, so it looks something like this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"
    
  8. Save the file

  9. Run update-grub as root (Note: This will regenerate grub.cfg and probably overwrite any changes that may have existed there! Use with caution and maybe update grub.cfg manually instead of following steps 5 through 9.)

So the answer is: The nomodeset kernel option.

0

In case somebody will have some weird display results (like me in Debian 8 with kernel 3.16.0-4-amd64, hardware: ThinkStation P300, ThinkCentre M93p ):

Edit grub config file: /etc/default/grub and add to (remember kernel parameter separator is just space ""): GRUB_CMDLINE_LINUX_DEFAULT="video=VGA-1:1280x1024@60me" and then update-grub

https://bugs.freedesktop.org/show_bug.cgi?id=45336

To summarize it's Intel's AMT headless bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.