2

I used these settings to set up exim to use gmail as a smarthost, which worked. However, I don't seem to be able to use these settings against other smtp servers, such as Yahoo or Fastmail (both with port 465 instead of 587). Both of these fail with the message defer (-18): Remote host smtp.example.com [x.x.x.x] closed connection in response to initial connection. Is there anything wrong with these settings? What could be going wrong?

my_route:
  driver = manualroute
  domains = ! +local_domains
  transport = my_relay
  route_list = * smtp.mail.yahoo.com

my_relay:
  driver = smtp
  port = 465
  hosts_require_auth = $host_address
  hosts_require_tls = $host_address

my_login:
  driver = plaintext
  public_name = LOGIN
  hide client_send = : [email protected] : my_password
3
  • Could you add output of the "# exim -d+all [email protected] < /dev/null" to your question?
    – ALex_hha
    Commented Aug 30, 2013 at 15:06
  • It's working now. I'm not sure exactly what was going on, but I think at least part of my problem was misunderstanding what (-53): retry time not reached for any host meant. Commented Aug 30, 2013 at 16:06
  • Additionally I had the Fastmail password wrong as I thought I could use an Alternate Login, and it's possible that Yahoo have blocked me as they sent me an email asking me to change my password due to suspicious activity. Having said all that I didn't get any meaningful error messages. Commented Aug 30, 2013 at 16:20

1 Answer 1

0

Had same challenge and solved it by changing smtp port from 465 (SSL/TLS) to 587 (STARTTLS).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .