1

I'm working on a project right now that sends email as confirmation of purchase. Some emails are still being received as spam. I have signed the domain up for google apps for business & am using the PHPMailer code base (that is used for sugarCRM, drupal etc..) to send email via googles servers using smtps. I realize that the body content of the message itself could be responsible..

However what I'm having a hard time understanding is the headers. The domain ourgreatmovie.com shows up in numerous parts of the header. This was originally the domain we were using until we changed to turnofthiscentury.com. I thought it might have been due to the reverse DNS pointer that I had setup for the old domain - however I've had my hosting provider change this to the new domain & have verified the change.

Furthermore, I've checked /etc/hosts file; nothing there - same for /etc/sysconfig/network (CentOS 6); not sure anymore where this domain is coming from; sample copy of headers received at destination are below: Thanks in advance!

Received: by 10.205.75.199 with SMTP id zb7csp33558bkb; Thu, 29 Aug 2013 10:03:53 -0700 (PDT)
Received: from ourgreatmovie.com (turnofthiscentury.com. [199.103.57.26]) by mx.google.com with ESMTPS id mc6si19213371icc.79.1969.12.31.16.00.00 (version=TLSv1 cipher=RC4-SHA bits=128/128); Thu, 29 Aug 2013 10:03:52 -0700 (PDT)
Received: from ourgreatmovie.com (localhost.localdomain [127.0.0.1]) by ourgreatmovie.com (8.13.8/8.13.8) with ESMTP id r7TCAYLw020926 for <reeceg@tbadigital.com>; Thu, 29 Aug 2013 08:10:34 -0400
Received: (from apache@localhost) by ourgreatmovie.com (8.13.8/8.13.8/Submit) id r7TCAYgg020925; Thu, 29 Aug 2013 08:10:34 -0400
X-Received: by 10.43.53.144 with SMTP id vq16mr1714222icb.41.1377795832986; Thu, 29 Aug 2013 10:03:52 -0700 (PDT)
Return-Path: <apache@ourgreatmovie.com>
Received-Spf: neutral (google.com: 199.103.57.26 is neither permitted nor denied by best guess record for domain of apache@ourgreatmovie.com) client-ip=199.103.57.26;
Authentication-Results: mx.google.com; spf=neutral (google.com: 199.103.57.26 is neither permitted nor denied by best guess record for domain of apache@ourgreatmovie.com) smtp.mail=apache@ourgreatmovie.com
X-Php-Originating-Script: 0:class.phpmailer.php
Message-Id: <462bedcaa876c16c2cd449a0aef4c23a@turnofthiscentury.com>
X-Priority: 3
X-Mailer: PHPMailer 5.2.6 (https://github.com/PHPMailer/PHPMailer/)
Mime-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
2

Looks like it's what the mail server program is sending as it's HELO/EHLO.

Check this setting in your mail system: smtp.mail=apache@ourgreatmovie.com as well as any settings for how the server identifies itself during SMTP setup/communication.

Check these 2 links for reference:

How to Specify outgoing HELO with sendmail?

https://stackoverflow.com/questions/5672651/change-helo-host-name-when-sending-email

  • Thanks, this would have taken me some time to figure out on my own. – Reece Aug 30 '13 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.