3

I got issue on my openSuSE instances. By default in openSuSE after installation by gem utility (gem install some_app) you will got something like that:

# some_app1.9
# chef-solo1.9

etc.

That a bad behaviour especially if you want automate stuff.

  • FYI -- the right way to answer your own question is by adding the answer as an answer (so other people can upvote it, and so the question shows as answered), rather than editing the question to include its own answer. – Charles Duffy Aug 25 '14 at 23:05
2

I try to find out how to remove this appendix/suffix and find a solution based on this article:

  1. Install ruby19-devel-extra by zypper install ruby19-devel-extra
  2. Second install gems by adding option "--no-format-executable":

    gem install chef --no-format-executable
    
  • If you aren't using rvm you are most likely wasting time. – Deer Hunter Jul 24 '15 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy