0

We configure cluster with rhcs with storage partition.we created pv and vg. we can see pvdisplay and vgdisplay with all information about pv and vg which we created.

But we can not see vg file on /dev , /dev/mapper and therefore not able to format it and use.

please suggest to resolve this problem.

root@S1 mapper]# pvcreate /dev/mapper/mpath01
  Physical volume "/dev/mapper/mpath01" successfully created

[root@S1 mapper]# vgcreate cgdemo /dev/mapper/mpath01
  Clustered volume group "cgdemo" successfully created

[root@S1 mapper]# vgdisplay

  --- Volume group ---
  VG Name               cgdemo
  System ID            
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  1
  VG Access             read/write
  VG Status             resizable
  Clustered             yes
  Shared                no
  MAX LV                0
  Cur LV                0
  Open LV               0
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               1024.00 GiB
  PE Size               4.00 MiB
  Total PE              262143
  Alloc PE / Size       0 / 0  
  Free  PE / Size       262143 / 1024.00 GiB
  VG UUID               GgtiwS-b5M5-xQtA-7zJ2-swU9-m8Bw-vjM8IT

we set locking_type 3 in lvm.conf

6
  • Did you start clvmd daemon??
    – Petter H
    Sep 1 '13 at 16:02
  • Yes clvmd is started. I can see vgdisplay and pvdisplay from both nodes. Sep 1 '13 at 16:36
  • What does lvscan show?
    – DerfK
    Sep 1 '13 at 16:38
  • did you vgchange -a y cgdemo
    – Petter H
    Sep 1 '13 at 16:43
  • yes, i tried with vgchange -a y cgdemo, cmd runs fine, but can Sep 2 '13 at 5:23
6

Your vgscan output shows that you have not allocated any space from the volume group to logical volumes:

Alloc PE / Size       0 / 0

You need to use lvcreate to create a logical volume in order to have a device to format eg

lvcreate -L50G -nvolumename cgdemo

to create a 50GB volume named volumename using space from group cgdemo.

6
  • yes, currently no lvm created. But my confusion is that why i can't see vg in /dev or /dev/mapper Sep 1 '13 at 16:52
  • You don't see volume groups, you see volumes. What could you possible do with a volume group device that would be useful?
    – Zoredache
    Sep 1 '13 at 20:42
  • i tried to add a lvm to that vg, but in that case also i can't see lvm or vg file in /dev , /dev/mapper. as per my understanding, if we create vg then vg file must show in /dev , /dev/mapper Sep 2 '13 at 5:25
  • you lvm will probably show up in /dev/cgdemo/lvname Sep 2 '13 at 6:26
  • 1
    @user1688045 I've never had a device for the volume group itself, it has always been a folder with logical volume devices in it. You can try vgscan --mknodes but its manpage says it only creates dev entries for active logical devices, so it will probably not do anything. Device mapper only creates dm-* devices for the logical partitions.
    – DerfK
    Sep 3 '13 at 13:41
0

Volume groups are directories, created (I assume) as soon as you create at least one volume in that group.

You can try to create the directory by hand - use at your own risk.

What could you possible do with a volume group device that would be useful?

I found this question because I though I would have to use a device in virt-install commands and libvirt XML files, but I had a second look now and they turned out to be group names and directories instead:

virt-install [...] pool=vmgrp,size=50,[...]

/dev/vmgrp/[...].img

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.