When I run my application I get the following error:

*** Operational MODE: single process ***
unable to load app 0 (mountpoint='') (callable not found or import error)
*** no app loaded. going in full dynamic mode ***

The command I use to run it is this:

/usr/local/bin/uwsgi -L -w app:app --ini /etc/configuration/uwsgi/uwsgi.ini --uid deploy

My uWSIG configuration looks like this:

socket =
master = true
processes = 1
pidfile = /tmp/app-uwsgi.pid
chdir = /etc/application

My supervisor configuration looks like this:

file=/tmp/supervisor.sock   ; (the path to the socket file)

logfile=/var/log/supervisord.log                  ; (main log file;default $CWD/supervisord.log)
logfile_maxbytes=50MB                             ; (max main logfile bytes b4 rotation;default 50MB)
logfile_backups=10                                ; (num of main logfile rotation backups;default 10)
loglevel=info                                     ; (log level;default info; others: debug,warn,trace)
nodaemon=false                                    ; (start in foreground if true;default false)
minfds=1024                                       ; (min. avail startup file descriptors;default 1024)
minprocs=200                                      ; (min. avail process descriptors;default 200)
; user=supervisor_user                            ; Running as root is better than nothing

serverurl=unix:///tmp/supervisor.sock             ; use a unix:// URL  for a unix socket

supervisor.rpcinterface_factory = supervisor.rpcinterface:make_main_rpcinterface

command=/usr/local/bin/uwsgi -L -w app:app --ini /etc/configuration/uwsgi/uwsgi.ini --uid deploy

Where am I going wrong?


To get this working I needed to specify the virtualenv location in the uwsgi ini, then it worked just fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.