I am trying to add passenger_root and passenger_ruby to my nginx.conf file, but when i try and restart NGINX I get the message:

Starting nginx: nginx: [alert] Unable to start the Phusion Passenger watchdog
because its executable (/usr/lib/phusion-passenger/agents/PassengerWatchdog) does not 
exist. This probably means that your Phusion Passenger installation is broken or 
incomplete, or that your 'passenger_root' directive is set to the wrong value. Please 
reinstall Phusion Passenger or fix your 'passenger_root' directive, whichever is 
applicable. (-1: Unknown error)

In my nginx.conf file:

http {
    passenger_root /home/deploy/.rvm/gems/ruby-2.0.0-p247/gems/passenger-4.0.14;
    passenger_ruby /home/deploy/.rvm/wrappers/ruby-2.0.0-p247/ruby;

Those are both valid paths

I looked at this post: nginx-not-acknowledging-passenger-root-option and tried to run

 apt-get remove nginx

but it tells me nginx is not installed. I am using RVM + Passenger + Nginx

I installed passenger by running gem install passenger. Nginx was previously installed, and I just tried modifying the path to the new version of passenger in the nginx.conf file. Do I need to do something additional to make the two work together?

If I try to run sudo passenger-install-nginx-module

I get the message:

Nginx with Passenger support was successfully installed.

Please edit your Nginx configuration file (probably /opt/nginx/conf/nginx.conf),
and set the passenger_root and passenger_ruby configuration options in the
'http' block, like this:

  http {
      passenger_root /var/lib/gems/1.9.1/gems/passenger-3.0.19;
      passenger_ruby /usr/bin/ruby1.9.1;

That is the old ruby path... if i run rvm info, i get the proper ruby2.0 paths

  • Look for any other passenger_root directives in your configuration. – Michael Hampton Sep 4 '13 at 19:53
  • check out the last part of my post now, i editted it. when i try to install passenger-install-nginx-module, it still looks like its trying to get to the old ruby path my new path is in /home/deploy (single user install) – Joel Grannas Sep 4 '13 at 20:02
  • you should not use sudo try rvmsudo instead - but if you skip then the installer should tell you what to do anyway. – mpapis Sep 13 '13 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.