The subversion package which is available from the Ubuntu 9.04 repositories has a very annoying limitation which make it basically unusable for repositories hosted on https://. The accepted solution to this problem is to compile subversion by hand from the sources hosted at Tigris, being sure to configure using the --with-ssl option.

This works fine for the svn CLI client, but it breaks down with respect to other tools which use libsvn. I'm assuming that the hand compilation bit does install the corrected libsvn .so(s), but they are not used by packages like git-svn which are installed via APT.

So, here's the question: how do I get git-svn working on Ubuntu with repositories hosted on https://?


Until this is fixed in the ubuntu repositories, you are probably better off compiling git and git-svn yourself as well. Just make sure when you compile git-svn that you point it to the right libraries in the configure.

I even tried upgrading to the karmic packages for libsvn1, libsvn-perl, subversion, git-core and git-svn with all their dependencies and still no luck.

  Installed: 1:
  Installed: 1:
  Installed: 1.6.1dfsg-1ubuntu2
  Installed: 1.6.1dfsg-1ubuntu2
  Installed: 1.6.1dfsg-1ubuntu2

Seems to be related to this ubuntu bug. Also thanks for diagnosing this, it's a problem I was about to learn I had.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.