2

I am trying to use Amazon S3 to host my webiste. I have the domain registered though namecheap. Whenever I navigate to mywebsite.com the URL in the browser changes to http://mywebsite.com.s3-website-us-east-1.amazonaws.com/. I would like the URL in the browser to stay unchanged, but really have no idea how to fix it. Here are few screenshots of my setup. I'd appreciate any help.

namecheap DNS setup namecheap DNS setup

Route 53 setup enter image description here

2

DNS has a limit. The top level of a domain must be an A record, it cannot be a CNAME. For example, serverfault.com cannot be a CNAME, it must be an IP address, because that’s what the value of A records are. IP addresses. Try changing the A record to point to an IP address (could be the IP address of s3-website-us-east-1.amazonaws.com & then add another ALIAS record if needed.

| improve this answer | |
  • 1
    Where is OP referencing an apex? – Jack Sep 12 '13 at 9:21
  • 1
    I thought that's what he mentioned when he said mywebsite.com. – deppfx Sep 12 '13 at 9:25
  • 1
    You're right. I missed that part :) – Jack Sep 12 '13 at 9:44
2

According to the guides, Amazon advices you to create two buckets:

  • mywebsite.com
  • www.mywebsite.com

One of those buckets will be used to host the actual site (Enable web hosting), the other is used as a domain redirect (Redirect all requests to another host name). Both buckets are then added to Route53 in the same manner, using an ALIAS.

You can find more information in this detailed guide and here.

| improve this answer | |
0

My problem ended up being caused by DNS caching. Running ipconfig /flushdns from the command line as well as flushing the cache in Chrome and Firefox did the trick.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.