0

I've getting problems copying files from one Windows 2012 server to another via Cisco ASA5505 VPN. I've had a similar setup with Win2008 servers & never saw the problem (same ASA5505 this end)

For about 1 in every 20 files (once or twice a day) of about 20MB or more, I tend to get data corruption.

The corruption tends to be in the form of about 5 areas of corruption, (sometimes all localised within a 1MB section of the file), and each area is about 12 bytes long, totalling in approx 60 corrupt bytes in the whole file. The file size does not change.

I've seen this with the native SQLServer log-ship-copy and with robocopy.

Connected with this is that when I use windows drag/drop to copy a 40GB file, the copy usually fails around after 15-30GB (or copies with some corruption). This doesn't seem to happen when I copy Win2012 -> VPN -> SBS2011, then copy SBS2011 -> Win2012.

Compression does not appear to be enabled on the ASA5505. No errors spotted on a the standard NetMonitor SMBErrors trace.

1

It was the VPN (or network - TBC), not a Windows issue.

Here's how I found it.

After running Microsoft Network Monitor at both ends of the VPN, I managed to capture a TCP/IP packet relating to corrupt file content. The packet captured at the remote end had no corruption. The packet at the destination was corrupt.

To find the bad network packet, I hex dumped the good and bad version of the file, then used KDiff3 to compare the hex. I then searched the NetMonitor capture for a 4-byte hex pattern that occurred just before the corruption in the file. I couldn't find this pattern so I tried another pattern just after the corruption, found it, then worked backwards through the bytes to the block in question (the first pattern crossed a packet boundary).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.