I have successfully installed the recommended fluentd stack ( fluentd, Kibana, Elastic Search ) on a Centos 6 virtual machine. But our production environment is all Suse Enterprise Linux 11.

I am trying to work out how to get fluentd installed but I am have a hard time with dependencies and other missing pieces. I am trying to use any one of these quickstart instructions and adapt them to my installation but I have just succeeded in breaking my install with incompatible versions of things like libc.so when I try and install or upgrade things to where they need to be.

What I really want to do is be able to use the RPM installer since Suse Enterprise Linux package manager is based on RPM packaging. I know this doesn't work, it broke my system to where I had to re-image it again. But I can't get it to install from source either.

I am an accomplished Googler and after 2 solid days of searching and reading and re-building my experimental VM, I am resorting to asking for help.

Here are the details of my environment:

wls1:~ # uname -a
Linux wls1 #1 SMP 2009-02-28 04:40:21 +0100 x86_64 x86_64 x86_64 GNU/Linux
wls1:~ # cat /etc/SuSE-release
SUSE Linux Enterprise Server 11 (x86_64)
wls1:~ #

NOTE: If you need any more details or information, please ask in the comments and I will update my question with the additional information!

  • Your link to "these quickstart instructions" seems to be missing. And, also, this. Sep 17, 2013 at 14:52
  • That doesn't seem to be the correct link. Sep 17, 2013 at 15:10
  • Your link to the instructions you supoosedly followed still doesn't point to anything that could possibly be what you were doing. Perhaps you should actually explain what you've done so far. Sep 18, 2013 at 18:13
  • It points to all the various instructions, none of which are really applicable to SEL. I need some help with modifying one of the instruction paths with what to modify for SEL. For example the "from source" link on that page doesn't work on SEL. That is the page I wanted to be linked to. It isn't incorrect, this is the link I intended to post!.
    – user35861
    Sep 19, 2013 at 14:51
  • 1
    I have a working fluentd install instructions for a vanilla SLES 11 SP3 VM. They involve deploying build environment and libs from Novell repos and building ruby and fluentd from source (no complications). I can clean these up and post as an answer if you like, however since you are now talking about Kibana init.d scripts, it looks like you are already OK with that part? In which case have you looked at novell.com/coolsolutions/feature/15380.html and/or tried to adapt and existing ruby based init.d script for SUSE/openSUSE?
    – ab77
    Sep 20, 2013 at 14:21

1 Answer 1


Ok, here is a procedure I used to install fluentd (from source) starting from a minimal SLES 11 SP3 install in a VirtualBox VM. It is based on this guide.

(1) download SLE-11-SP3-SDK-DVD-x86_64-GM-DVD1.iso (Product: SUSE Linux Enterprise Software Development Kit 11 SP3) from Novell and install using these instructions

$ yast
select Software -> Add-On Products
mount and select DVD1 of the SDK you downloaded from above
install with defaults

Note: this adds SDK repositories, which allow instillation of git, openssl-devel, etc., witch are required to build from source

(2) install build environment (compilers, make, etc.)

$ install -t pattern Basis-Devel

(3) install dependencies

$ zypper install git-core
$ zypper install openssl-devel

(4) download and build ruby from source (the version in the Novell repos is not suitable for fluentd)

$ mkdir -p /opt/install
$ cd /opt/install
$ curl http://cache.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p247.tar.gz > ruby-2.0.0-p247.tar.gz
$ tar -xvf ruby-2.0.0-p247.tar.gz
$ cd ruby-2.0.0-p247
$ ./configure
$ ./make install

(5) build and install fluentd

$ cd /opt
$ git clone https://github.com/fluent/fluentd.git
$ cd fluentd/
$ gem install bundler
$ rake build
$ gem install pkg/fluentd-0.10.39.gem
$ fluentd --setup ./fluent
$ fluentd -c ./fluent/fluent.conf -vv &

(6) test fluentd

# test
$ echo '{"json":"message"}' | fluent-cat debug.test

(7) create start-up scripts using Novell's template or a number of other SUSE/ruby init scripts you can find on the Web.

Try running this on your test VM first, but it should work as I've just done it and it worked for me without errors.

-- ab1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy