0

I have this folder three in Windows Server 2012:

Projects
   |-> A
   |-> B
   |-> C
    ...
   |-> X
   |-> Y
   |-> Z

I want to share the folder Projects with Programmers group, but not all folders, only specific ones.

After share the Projects folder i am trying to select all folders that are inside it and use Share with -> Stop share, but all users of the group Programmers still can use the folders.

I am starting to use this SO now, so it probably is a noobie question, but i will be glad if someone can help me.

2 Answers 2

2
  1. You're not sharing the sub-folders. You're sharing the Projects folder. The sub-folders are accessible via the "parent" share.

  2. Make sure you have the correct NTFS permissions set on the sub-folders so that the Programmers group only has access to the sub-folders that you want them to access.

  3. Use Access Based Enumeration on the parent share. This will make it so that the Programmers only see the sub-folders that they have access to. They won't see any sub-folders that they don't have access to.

1
  • Glad to help...
    – joeqwerty
    Sep 17, 2013 at 19:26
2

You can not do it exactly the way you are asking. You need to share the folder and everything underneath, then set security permissions on the subfolders to deny where appropriate.

4
  • 1
    In addition, if necessary enable ABE (access based enumeration) on the server (you'll need the File and Storage Services role), so that they only see the folders in the share they have rights to see.
    – TheCleaner
    Sep 17, 2013 at 15:39
  • 2
    You beat me to it, TheCleaner
    – joeqwerty
    Sep 17, 2013 at 15:41
  • @joeqwerty - TheCleaner? Don't you mean MDMarra? #evillaugh
    – TheCleaner
    Sep 17, 2013 at 17:50
  • Good one. You're right, MD... ; ;
    – joeqwerty
    Sep 17, 2013 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.