I discovered a change in some recent version of ProFTPd - I used Umask 0007 to remove permissions to "others" but it kept my SetGID directory flag - which is what I wanted.

In recent version (1.3.4) my permission system stopped to work. I am unable to convince ProFTPd to set SetGID flag on newly created directories.

In documentation they say "base-mode" for creating directories is 0777 and UMask allows only to remove permissions.

How to make it set SetGID bit on new directories, that is permissions 2770?



OKay, answering my own question: I did not find the cause of this, but when I enabled mod_vroot plugin and added VRootEngine on, everything went back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.