I have a W2K3 server that's an AD DC. It has a GPO in place that directs users' Desktop and My Documents folders to \\oldserver\Users$\<username>. I wanted to migrate their folders to another file server. I already have it so their logon script successfully maps H: to the new server, and the AD DC is no longer sharing these folders.

In case it's relevant, the GPO looked like this:

  1. GPO security:
    1. Authenticated Users: Read and Apply are granted
    2. WMI filter: none
  2. 1st tab:
    1. Setting: Basic
    2. Target: Create a folder for each user under the root path
    3. Root Path: \\oldserver\Users$ ("for the user Clair... \\oldserver\Users$\Clair\Desktop" which was correct)
  3. Settings tab:
    1. Grant....check
    2. Move....not checked (also tried checking this off and rebooting/gpupdateing client in response to an answer; same result)
    3. Policy removal: Leave the folder...
  4. Every single other GPO in the domain says "Not configured" for this setting

However, when I changed the GPO to point to \\newserver (or better yet, to just H:\, which also has no effect), it doesn't seem to take effect, because logging in to an XPSP3 box as a user gives the error:

Program Manager

\\oldserver\Users$\user\Desktop is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The network path was not found.

This is despite the fact that:

  1. On that user's machine, I have run gpupdate successfully, and restarted the machine (even though it's a user policy, not a computer one)
  2. On oldserver, gpresult /s oldserver /user MYDOM\user prints out Standardized home folders (the GPO in question) directly under the user Applied Group Policy Objects section
  3. If I go reopen the GPE, it successfully stored the new path in the Standardized home folders GPO (the only one by that name. I have very few GPOs.)

I don't understand: if gpresult says the GPO was applied, why does it complain about a path that's no longer part of the GPO?


You need to enable the option "Move contents to the new location..."

From TechNet:

Allow Folder Redirection to perform all the moving of folders and files when you select a folder for redirection or change the target network share to which you redirect the folder. The Folder Redirection client not only moves files to the appropriate network share, but it also sets proper folder security and renames entries in the Offline Files cache database so that they continue to link to the correct target folders and files. Any files pinned by the user in the Offline File Cache stay pinned.

  • I'll try this, but since I'd already stopped sharing from the old server, I didn't think it was a good idea, since it'd be looking to move from something that didn't exist. I.e.: I already did all the moving myself, and have Offline Files completely disabled on this domain. – Kev Sep 22 '13 at 0:49
  • Sorry, same result, even after a gpupdate /force and a reboot. – Kev Sep 22 '13 at 0:53
  • I'm thinking it's already broke and you may have to redo it from scratch. Do you have all of the data backed up? If so, recreate the original share, set the GPO back to it's original settings (make sure to enable the "Move contents..." option), log on and verify that the old path is being used, then change the GPO path and log off and back on to see if the data has moved to the new location. I've moved the Folder Redirection target many times and haven't had this issue but I've always had the "Move contents..." option enabled. – joeqwerty Sep 22 '13 at 0:59
  • so you're saying it's because I disabled the old share that it's still looking for the old one before it will change it to the new one? (Wouldn't unchecking the "Move contents" option actually help in this case?) – Kev Sep 23 '13 at 2:31
  • I tried what you said, but it never seems to acknowledge the new path. – Kev Sep 23 '13 at 2:37

Definitely not my favourite answer, but I just searched the registry on the client and found that changing the paths under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders made it work after a logoff/logon (even with a drive letter path rather than UNC, which was one nice thing.)

If I go with this though then I need a nice way of propagating this registry change to all other clients. I guess I'd stick something in netlogon, like a .reg file with the above export, and then regedit /s homefix.reg in the logon.cmd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.