1

I have setup WDS on Windows 2008 server in a Vmware box so I can practise setting up WDS,the server has DNS and DHCP as well as AD, the boot image is confirmed as working but when my clients try to boot up it does not work.

I have checked the following:

  • Clients can ping the WDS server.
  • The WDS service is started
  • Boot images for X86 and X64 are deployed.
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WDSServer\Providers\WDSPXE
  • UseDhcpPorts has been set to 0

My clients just receive Error: PXE-E53: No boot filename received.

Any idea what could be wrong?

0

In the DHCP tab of the WDS server properties, do you have both 'Do not listen on Port 67' and 'Configure DHCP option 60 to indicate that this server is also a PXE server' options checked as described in the TechNet article 'configuring DHCP'?

Hope this helps,

  • I have both ticked yes. – Ninja2k Sep 23 '13 at 18:58
  • @Ninja2k Can you run WDSUTIL /Get-Server /Show:config and post the results? – dwolters Sep 23 '13 at 20:44
  • Here is the output pastebin.com/HG03itXN – Ninja2k Sep 26 '13 at 9:56
  • 1
    Is your network adapter set to bridged or was it left on the default NAT setting? It should be set to bridged. You might also want to turn on logging on your WDS server according to the TechNet article 'Logging and Tracing – dwolters Sep 26 '13 at 19:50
0

Because you use DHCP and WDS on the same Server you should use those settings:

  • on WDS Server in properties DHCP Tab check the two Options or run WDSUTIL /Set-Server /UseDHCPPorts:No /DHCPOption60:Yes
  • on DHCP Server be sure to not configure option 66 and 67 - only option 60 should be configured from wds server
  • on the network interface on TCP/IPv4, disable WINS! (only needed on Windows Server > 2008 R2)
  • check your firewall to open port 67/UDP (DHCP), 69/UDP (TFTP), 4011/UDP (PXE)

When all dont help, try first to re-add your boot.wim's - when this also won't help, try to uninitialize your Server (wdsutil /Uninitialize-Server) and Initialize them again with same path (your drivers and images should not be touched - but better you create a backup before!)

When you have other subnets behind a gateway, use a dhcp-relay-agent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.