0

I've bought a VPS from a hosting provider and I want to set it up. The server is a CentOS-6.4 and the provider installed WHM on it, so it has apache installed as well.

I have 3 IPs available and I managed to install nginx and make it listen on one of the IPs, while apache still responds to the first IP and WHM/CPanel works fine.

My issue is with getting nginx to function properly. It works fine serving HTML content, but for PHP it needs php-fpm or similar to work.

I've read countless blog posts about how to get this to work and they all say: "add the epel.repo and remi.repo, set priorities and yum install php-fpm and whatever extension you might need.

The problem is when I try to yum install, I get:

No package php-fpm available.
No package php-cli available.
No package php-mysql available.
No package php-gd available.
No package php-imap available.
No package php-ldap available.
No package php-odbc available.
No package php-pear available.
No package php-xml available.
No package php-xmlrpc available.
No package php-magickwand available.
No package php-magpierss available.
No package php-mbstring available.
No package php-mcrypt available.
No package php-mssql available.
No package php-shout available.
No package php-snmp available.
No package php-soap available.
No package php-tidy available.
Error: Nothing to do

Any clues as to why it's not working?

marked as duplicate by Jenny D, Michael Hampton Sep 25 '13 at 13:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • what us output of "yum search php" – Farhan Sep 25 '13 at 9:36
  • pastebin.com/LAXPHH0g – Mihai Sep 25 '13 at 9:44
  • instead of manually going through installation php-fpm+nginx, you should try this: applications.cpanel.net/… – Farhan Sep 25 '13 at 9:51
  • will i be able to use varnish with this ? i tried using cpxstack but had some issues with the fpt accounts after installing and thought i'd do the install from scrathc – Mihai Sep 25 '13 at 10:52
0

I think your problem would be solved using the command:

yum --enablerepo=remi install php-fpm

to install php-fpm, if you've added the repo previously.

  • I've enabled both the epel and remi repos through their respective config files. I've set 'enabled=1'. I've also tried your approach at first. still no luck. It's strange though that 'yum search php-fpm' returns no results. – Mihai Sep 25 '13 at 12:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.