I have a Dovecot mail server running an everything is working fine - all emails arrive and new messages can go out.

To give the users the possibility to read their emails and to write them, i have installed an RoundCube webmailer. It is working all

The emails are stored in mbox format, so in a single file.

Now to the problem:

When an email is deleted via the webmail interface, it is still there - when i reload the view, the mail is showed grayed out. I have also tried to move it to the trash manually and then delete it from there - but they are still grayed out in the inbox.

Regards and thanks for the help

  • Is dovecot showing any errors in its logs? Does dovecot have permission to write to the mbox file? – Kyle Sep 25 '13 at 17:05
  • that is not the problem - i've tried to set 777 (only for testing, security etc.) and it still didn't work. Another thing is, that ls is showing me, that the last editing date was the 22nd September 2013, so not today - meaning, that dovecot did not even wrote to it ... – PDev Sep 25 '13 at 18:07

When you "delete" somthing in IMAP it does not usually get deleted immediately, instead the /deleted flag gets set on the message. That message will sit on the server until either an IMAP EXPUNGE command is received for the mailbox, or doomsday arrives.

There should be a button in RoundCube to perform an expunge operation [also referred to as 'compacting' the mailbox in other clients] and/or an option to expunge on logout.

  • I have googled a lot and found out, that i have to set the chomd -t permission to /var/mail - that helped and now the deletion of emails is possible. Roundcube itself does, as i thing, the imap expunge when deleteing emails from trash automatically - the first deletion itself is just a move to another folder, and already that didn't worked out. – PDev Sep 25 '13 at 18:19

Check you configuration file. Be sure to add the add_privileged_group directive set to the right group (mail).


Restart the dovecot daemon. You should now be able to delete your emails, from your MUA interface.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.