Background info: we're running on a network where we don't control DNS or DHCP, but we run a domain within it. We are trying to use WDS with a discovery image pointing to our WDS server.

Odd issue -- we started with WDS running on Windows 2012, properly configured and verified working on our older test machines. The machine boots up, reads the boot image off of the USB drive, and brings us to the 'Choose your language' page, then prompts for credentials before showing the list of available images.

We then moved to our computer labs, where the machines are a little newer. This time, it boots, pulls an IP, and then gets to the generic "WdsClient: There was a problem initializing wds mode". We checked the server logs, and it seems to be failing because there is no boot image available for "x86uefi" architecture. The thing is, we're using an x64 WinPE image to start a Windows 7 x64 boot image, and trying to deploy Windows 7 x64. We don't want x86uefi, but can't seem to find a way to force it to ask for that.

We've tried an x86 WinPE image and an x86 boot image, but we get the same error.

We then tried using WDS running on 2008 R2, and are having the same problem.

When we hit shift+F10, we can see that the clients are pulling IPs from DHCP and are pinging the server just fine. It just doesn't want to run. The event logs show that it asks 10 or so times before it craps out.

  • On 2008 R2, the architecture it thinks it's looking for is "Arch: 6" which seems to be EFI IA32 -- again, it wants EFI, but we want regular x64.
    – atmarx
    Sep 26 '13 at 14:31

Have you tried changing from UEFI mode to legacy BIOS or BIOS-compatibility mode on the PC? The TechNet article ‘Boot a PC in UEFI Mode or Legacy BIOS-compatibility mode’ should help.

You may also want to read more about UEFI Firmware, as more machines will be made with UEFI and you will want to incorporate this into your deployment strategy.

Hope this helps,

  • Thanks for the suggestion. These are on Optiplex 960s with UEFI disabled and boot mode set to legacy. We are not interested in pushing out UEFI yet. On our test bench we have DHCP and WDS, and have no issue getting these to boot and pull the correct architecture. It's only when using the discovery image that it can't get find the right image.
    – atmarx
    Sep 27 '13 at 16:43
  • @Andrew Have you updated the BIOS on those machines? There is a BIOS update dated 9/3/2013 on the Dell website, hopefully that will help.
    – dwolters
    Oct 4 '13 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.