3

Been fighting with a real odd one here... Long before I started at my current company, there was an exchange 2007 server in the network. We believe it was simply dropped and not properly removed. Now fast forward to today. We recently completed an implementation of Exchange 2013 then decomissioned the 2010 server, fully removing it as it should be removed and it no longer shows up anywhere. The problem? On the 2013 server, running Get-ExchangeServer shows two..... The current one at v15 and this older, nowhere to be found one ServerRole = "Provisioned" at v8.2. I have tried to rebuild using a 2003R2 server base named the same as the original host and running the same original IP and Exchange 2007 without luck. Running "server /m:RecoverServer" says no server of that name found in AD.

ADSIEdit shows something interesting below the "Exchange Administrative Group", namely a CN=Servers entry with the proper new 2013 in it only, and a "CN=Server Backups" with entries that match the long dead machine. Some other issues lead us to believe some tasks are still trying to contact this old server and we would like to just KILL all references to this older box. Unfortunately it appears that all the normal tricks of the trade come up empty, yet the primary exchange server still thinks this BACKUP machine (yea, lousy name for it!) is still out there, at least provisioned. Any advice?

  • 2
    Solved it myself. Looks like the only path was to run "Setup /RemoveProvisionedServer:<servername>" directly from the replacement server. This cleared it and after AD propigation checking from the Exchg2013 server shows the entry is gone.... – Michael Kovacs Sep 27 '13 at 16:54
  • 1
    You should answer the question yourself and mark it accepted. – Evan Anderson Apr 9 '14 at 21:54
1

I'm posting this as answer on behalf of Michael Kovacs

Solved it myself. Looks like the only path was to run Setup /RemoveProvisionedServer:<servername> directly from the replacement server. This cleared it and after AD propigation checking from the Exchg2013 server shows the entry is gone....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.