1

Looking here I can see extracting a downloaded mpam-fe.exe and copying the files to a shared folder should allow me to run the following command from an MSE client so it will pull down the updates from the share:

MpCmdRun.exe -SignatureUpdate -"\myserver\MSE-Defs"

This does not work. When I run this and check the log (C:\Users\ME\AppData\Local\Temp\MpCmdRun.log) I see:

MpCmdRun: Command Line: "C:\Program Files\Microsoft Security Client\MpCmdRun.exe"   -SignatureUpdate -"\\myserver\mse\"
 Start Time: ‎Fri ‎Sep ‎27 ‎2013 08:52:07

Start: MpSignatureUpdate()
Update started 
Search Started (MU/WU update) (Path: http://www.microsoft.com)...

So its totally ignoring the switch and going out to http://www.microsoft.com. If I remove the default gateway from this computer's NIC config the update fails.

How do I actually make MSE pull down definitions from a UNC path?

edit: I know I can just run mpam-fe.exe and it will update, but I'm still curious about how to make the unc switch work

0

The command that you're running is not the command that the tutorial is telling you to run. You're missing the string "UNC"

MpCmdRun.exe -SignatureUpdate -UNC "\\myserver\MSE-Defs"

I don't know whether this is going to be Windows 8 specific, but when I tried it I had to have an x64 folder within the share, and I also had to include a path flag so my command looked like the following:

MpCmdRun.exe -SignatureUpdate -UNC -path "\\myserver\MSE-Defs"

I'd downloaded the mpam-fex64.exe file and placed it into \\myserver\MSE-Defs\x64

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.