I've got a server behind a router and I'm trying to use my server as my DNS and DHCP service. I have them configured correctly, and I can connect out through, but I cannot seem to get my router to forward DNS requests to the server. In my router settings I've disabled DHCP, I port forwarded port 53 to the server and I set the DNS to my IP of the server, and If I set a user computer to statically use the DNS in the adapter settings I can connect fine, but if I use dynamic settings, I get an error in the network and sharing center saying I could not find the DNS server.

I have a netgear R6300v2 router and a server running windows server 2008 r2. So, what gives? what settings do I have to change in my router for it get the DNS correctly? Statically coding the computers isn't really an option so please help? Thanks!


The reason it's only working when you set the DNS server addresses statically, is that the DHCP Server is not providing the DNS information to clients. In order for DHCP to provide the DNS Server address to a client, the DNS Server option needs to be enabled:

Per Technet (http://technet.microsoft.com/en-us/library/dd183679%28v=ws.10%29.aspx)

To define a new option

Open DHCP.

In the console tree, click the applicable DHCP server.

On the Action menu, click Set Predefined Options.

In Predefined Options and Values, click Add.

In Option Type, type the required information to define the new option, and then click OK.


Table 4.6 Common Information Option Types






DNS server


DNS domain name


WINS server (NetBIOS name server)


NetBIOS datagram distribution server (NBDD)


WINS/NetBIOS node type


NetBIOS scope ID

Clients can receive these values to set their TCP/IP configurations, during the period of the lease.

Edit to note that Routers do not by default forward DHCP requests, since DHCP uses Broadcasts to find DHCP Servers. You would then need to configure your router or another server to function as a DHCP proxy.

  • under server options I have an option name "006 DNS Servers" with a value of is that what you are referring to making? If so, it is already there. – john Sep 28 '13 at 21:23
  • Ah found, the problem, it was in there. I added the server IP address as another value (ie and it made it work fine. My question is shouldn't have worked as well? – john Sep 28 '13 at 21:25
  • 1 is localhost, meaning "this computer" or "myself", meaning that if you assign as the DNS server in your DHCP options then all of your DHCP clients will look to themselves (localhost - for DNS. - en.wikipedia.org/wiki/Localhost – joeqwerty Sep 28 '13 at 21:43
  • I actually discovered this recently on my DHCP server. It defaults to the localhost when you configure the server as a DHCP server and create a scope. – Davidw Oct 5 '13 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.