Our test server (based on windows 2008) crashed because of a power loss during the weekend.

After the restart, all services started successfully but Oracle 11.2 didn't.

I tried to start all services manually and it seems to be all right (I can log on SQL*Plus from Powershell)

But when we try to connect with Oracle SQL developer we got this

oracle error

I tried Googling the error code but I can't figure out what the problem is (I'm just a developer and I don't know much about system administration).


I followed the link posted by DanBig in this comment.

I renamed all the listener.ora files in the oracle installation folder and then rebooted.

Now it works all fine, thank you all :)

| improve this answer | |

The problem is that the database instance didn't register itself to the listener so the listener doesn't know the Oracle Sid you are referring to. Type in the following command as sysdba (cmd> ORACLE_SID=xxx cmd> sqlplus / as sysdba):

sqlplus> alter system register;

If it doesn't help, try to register the service with local listener define a static listener instead of dynamic registration.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.