1

I am running an internal httpd server that forwards requests to another httpd server. The internal httpd server acts as a proxy and also supports caching. I just upgraded from 2.2.11 to 2.2.25 of httpd. I have the same configuration as before. When an HTTP request comes in, I see several entries (one per second) for OPTIONS * HTTP/1.0 in my access_log. There are no errors in my error_log. What is this new OPTIONS * HTTP/1.0 that I never saw before? My old build used worker.c and this one seems to use prefork.c. I am not sure on the difference. Would this cause it? This is the only difference between my old build and this new build.

These are the modules I am using:

Compiled in modules:
  core.c
  mod_authn_file.c
  mod_authn_default.c
  mod_authz_host.c
  mod_authz_groupfile.c
  mod_authz_user.c
  mod_authz_default.c
  mod_auth_basic.c
  mod_file_cache.c
  mod_cache.c
  mod_disk_cache.c
  mod_mem_cache.c
  mod_ext_filter.c
  mod_include.c
  mod_filter.c
  mod_substitute.c
  mod_log_config.c
  mod_env.c
  mod_expires.c
  mod_setenvif.c
  mod_version.c
  mod_proxy.c
  mod_proxy_connect.c
  mod_proxy_ftp.c
  mod_proxy_http.c
  mod_proxy_scgi.c
  mod_proxy_ajp.c
  mod_proxy_balancer.c
  prefork.c
  http_core.c
  mod_mime.c
  mod_status.c
  mod_autoindex.c
  mod_asis.c
  mod_info.c
  mod_cgid.c
  mod_negotiation.c
  mod_dir.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_rewrite.c
  mod_so.c

The access_log:

::1 - - [02/Oct/2013:13:30:34 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:35 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:36 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:37 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:38 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:39 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:40 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:41 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:42 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:43 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:44 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:45 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:46 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:47 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:48 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:49 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:50 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:51 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:52 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:53 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:54 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:55 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:56 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:57 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:58 -0400] "OPTIONS * HTTP/1.0" 200 -
::1 - - [02/Oct/2013:13:30:59 -0400] "OPTIONS * HTTP/1.0" 200 -
2

These are internal dummy connections - see here.

Their appearance is due to your change of MPM from worker to prefork. You don't need to worry about them, but unless you have a reason to use prefork then you should probably be on worker.

  • This worked! Thank you.. Now on my httpd instance, I had to set ulimit -s 512 in my envvars under bin. I never had to set this before. The reason I had to set it was because I was getting an error trying allocate resources when I would start httpd. Any idea why now I have to set this? Maybe my ulimits were set to unlimited in my OS? – Brian Oct 2 '13 at 18:29
  • @0A0D Yeah, that's strange - have you customized any ulimit settings elsewhere? The default limits should easily be high enough for startup of the service without error.. – Shane Madden Oct 2 '13 at 19:00
-1

Check your servers /etc/hosts file. You probably have the entry for 'localhost' set to '::1' which is IPV6 format. Change it to '127.0.0.1' (IPV4) and this log message should stop appearing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.